Latest addition to the collection: Prefab Maker

Main Menu

Disappearing Models ?

Started by jonnyhilly, September 12, 2014, 02:47:47 PM

Previous topic - Next topic


Hi Im using mash maker on mac, iOS build settings, unity pro 4.5.2f1
Tried simply editing a cube into a wedge shape to make a slanted roof. Then I copied the cube detached the top so I had separate objects for the roof and walls of the wedge and put a different material on each (stone, and roof tiles)
all seemed good so far.
I can make prefabs with them, all still seems good.
But when I run the scene the meshes disappear.
The object is there, it has the materials, but the mesh is set to 'none'.
How do I fix this please ?

addendum... I can make the prefab...  but if I drag prefab back into a test scene, or look at prefab model in the inspector, the meshes are already gone. Its like the meshes are temporary and are not saved anywhere permanent. Am I missing a step in model editing to save out the meshes ?


Hi, there was a case with this happening to prefabs when using some of the tools but I thought this was fixed in the mesh editor. I will look into this and release an update soon. In the meantime you can use the save mesh tool in Mesh Tools to save a mesh to file and use this with the prefab to ensure that the mesh is saved permanently. The mesh will be saved to the Meshes folder within the main folder. I hope this helps until I can add a better solution to Mesh Editor.

I have fixed a problem with the undo/redo not working the second time the Mesh Editor is opened, so that fix will also be added to the update.


Thanks very much. I'll update to latest version in case I don't have that fix (my version is about a month old) and I'll use that save option !
Cheers !!


You're welcome. Actually, I forgot that in the latest version of Mesh Editor (v0.7.1) you will find that the save mesh option has been added to the program itself. This is handy since it allows you to save meshes at different stages of the editing process. I will add a save to prefab option too.

It slipped my mind as over the past month I have cleaned up the graphics, readme files, blurbs, tutorials, website, forum, main menu, GUIs and the source code for all seven programs and added an eighth program. So you will find a lot of changes when you grab the latest version.


That did the trick, thanks !!  :)
Just had to save the mesh, then re-apply to the mesh and collider slots.

Updated to latest version, and the "in-unity" buttons are great. Nice improvement.

A "Save prefab", option would be perfect!  cheers also for the fast response !

also gotta remember to have the "update normals" checked or the lighting is broken after editing.


unrelated... I can't edit the UV's...
I select a triange... then try the texture editing tools and nothing happens, If I try the other tools... flip / invert etc....  those seem to work ok.
any thoughts ?
I've looked in the docs, but they just say you can edit UV's by selecting triangle then hitting the buttons..
help appreciated, thanks.


When using the Transform Textures tool do you see a red outline on the triangles you have selected?

As a test, could you create a cube in a new project, add a texture to it, remove the box collider, add a mesh collider, open Transform Textures, hold left Alt while clicking on a triangle and then click on the transform buttons to check. This works in my case but if this doesn't work for you then please let me know.


sorry for slow reply, super busy...
created a cube, removed box collider, added mesh collider, added a diffuse material.
clicked meshMaker button, selected triangle mode and selected a triangle, whole triangle turns red.
Next select mesh tools, open transform-textures tab, and slide sliders and buttons. nothing happens to the texture
didn't try in a new project yet though.


I see what may be happening, it sounds like you are selecting the triangle with the Mesh Editor as you say the whole triangle turns red. Try just opening the Mesh Tools window by itself, hold left alt key while left clicking on a triangle and you should see just a red outline. Then the transform buttons and sliders should work for you.


Quote from: meshmakeGiant on September 19, 2014, 05:16:38 PM
I see what may be happening, it sounds like you are selecting the triangle with the Mesh Editor as you say the whole triangle turns red. Try just opening the Mesh Tools window by itself, hold left alt key while left clicking on a triangle and you should see just a red outline. Then the transform buttons and sliders should work for you.

Thanks, I tried that. Holding left alt and clicking on cube does nothing. (well sometimes the MeshTools window minimizes itself and flashes yellow a few times.)
When I press left-alt  Unity's pan icon in top-left corner changes to a hand (while I have alt pressed)  maybe alt/right click is already used ?   I tried re-assigning to Control, but with no luck.

forgot to mention, I am on a macbook pro. sometimes these limited laptop keyboards can affect things ?
also tried this with Cube, Sphere, and some random mesh prefabs, all with mesh colliders.
Also tried in a fresh new project, with fresh import of Mesh Maker.
have also tried this with default mesh with mesh colliders, and by saving mesh out with your tools, then re-applying that one as the collision mesh. makes no difference.

tried most of the other tool options, and they all seem to do something (as I don't need to select any polygons)
Its just the UV edit one doesn't work, as I need to select a polygon(s) and I can't

Maybe add a display showing number of polygons selected, and the current object selected info (you already have this on the Mesh Editor Tool)
Maybe also add, buttons for select next/prev poly. All and none  ?

New bugs possibly:-
click double sided mesh button. Works, but is there an undo ?  if you click it a few more times, then you get a bunch of errors... I think it just keeps on exponentially expanding/doubling the mesh until it crashes (>650000 verts in one mesh)

In Editor mode. Hotkey-click  can't select multiple polygons, can only select 1 at a time
Shift-Right click drag, does a look around the scene (rotates camera)... it does not select multiple polygons.

Maybe these are all Mac specific issues ?   haven't tried all this on PC.


I know the hotkey needs to be reassigned on the Mac which is why I added an option to select any hotkey from the list, but I can't say which hotkey is best to use that wont affect the other Unity functions. I will test this out on a Mac as soon as I can but if you find a key that works then please let me know. Perhaps this is also the case with selecting multiple triangles using the Mesh Editor. If the hotkey wasn't being acknowledged then it would act like it wasn't pressed at all which seems to be the case you are describing.

Mesh Editor has multiple selection of vertices which, by default, are left ctrl and right click to drag select and left shift to deselect. As it is still be Beta there is no multiple selection of polygons as yet.   

The next priority is to spend some time rewriting the Boolean Ops to make if far more robust for more complex models and to work easily in real time. Then I will get back to work on Mesh Editor and add full texture editing features to that program with unwrapping as well. I am also working on a full undo/redo system for all of the tools but for now I would suggest keeping a copy of the original mesh beforehand.

I have nearly finished another tool which adds Solids of revolution to the collection so look for that in a week + review time.


I tried a bunch of different hotkeys, all with no luck... I think they are probably all pre-assigned already... or get key-repeat issues.
Is the mouse pointer/icon supposed to change in any way once you have the correct hotkey held down ?
Maybe try a dual key approach ?
giving up for now.


Back, I've been working on the release of the next update. I think you are right, it may be that the key assigned needs the repeat behavior like the ctrl or shift key. The pointer shouldn't change so that seems to indicate that the hotkey is not working. There must be a Mac alternative that will work and as soon as I get a chance I'll run a bunch of tests to get this sorted. Thanks for your patience.