Latest addition to the collection: Prefab Maker

Main Menu

Can't Get Mesh Painter to Work

Started by magikarts, August 31, 2017, 05:19:32 PM

Previous topic - Next topic


I'm using Unity 2017 running on a 2015 MacBook Pro running Sierra 10.12.6.  I dragged a cube into the scene, removed the box collider and added a mesh collider.  I tried all combinations of Left Control/Left Command, Left Mouse/Right Mouse.  The button to change the hot key doesn't appear to work and using the mouse/control key combos just manipulate the scene navigation or manipulate the object. (right or left mouse click).  I also tried locking the mesh with the mesh editor and pressing texture mode; that didn't work.

I've read the documentation.  It says to make sure brush mode or text mode are selected. It doesn't say where or how do that or even what tool to change it in.  There's no brush or texture mode in Unity as far as I could tell except in the texture tool.  But then the object to paint is not selected. 

Please let me know how to get this tool working.  I need a good mesh painting tool and don't feel like spending the money when there's already a tool in mesh maker to do it.


Hello magikarts,

Thank you very much for your purchase and support. I also have a MacBook Pro which I purchased for testing the programs. It sounds like you have done everything right, such as removing the Box Collider and using the correct keys so I'm surprised to hear it isn't working correctly.

The control/command key is now the designated hotkey and it should work with a left click on the cube. The brush or texture mode mentioned in the documentation is simply a checkbox option on the Mesh Painter window.

Given that you appear to have tried everything I could recommend I will need to perform some more tests and I will try to resolve this. Please also note that I wrote this program a long time ago when I was just starting to create tools for Unity and as such it isn't that good. It's okay for adding some text notes to basic objects but don't expect much more from it than that.

Thanks again for your understanding and I will try to get back to you as soon as possible with my test results.

Best regards,