Latest addition to the collection: Prefab Maker

Main Menu

Recent posts

Support / Re: Level Editing Problems.
Last post by magikarts - September 03, 2017, 06:20:06 PM
I did check permissions on the files - they were read/write.  I made the change earlier because mesh painter wouldn't paint if the files were read only.
Support / Re: Level Editing Problems.
Last post by MediaGiant - September 02, 2017, 03:13:24 AM
First you would switch to Triangle mode within Level Editor, hold down the hotkey and click on a face (which will turn blue) and then press the Delete key. In Erase mode it will only erase the lines, but should be as easy as left clicking and dragging across the lines in the scene.

Thank you for the screenshot, it is puzzling to see that the PNG type is greyed out and I'm not exactly sure why this might be. It might be a permissions problem or a format issue since the blueprint was created in Windows. A bit more information can be found here at A way to test this would be to select another PNG file from the internet or elsewhere on the Mac. 
Support / Level Editing Problems.
Last post by magikarts - September 01, 2017, 09:31:42 PM
== Gear: MacBook Pro + OS 10. 12.6. 

== Delete
Tried selecting with a hot key and pressing the delete key.  Tried both the standard Delete key + ctrl-E (which deletes selected triangles in Mesh Editor).  Neither work in level editor.  Also tried selecting face then selecting the erase tool as well as selecting erase, then trying to select a face.  Also tried selecting lines. Nothing worked. Delete all works.  There is a work around: use the Mesh Editor or Mesh Cutter to delete what you want, but that involves saving the part and starting up another tool.

== Blueprints
All the legal file types (images) are greyed out, see screenshot.[blueprint load problem][www.]

Support / Re: Can't Get Mesh Painter to ...
Last post by MediaGiant - September 01, 2017, 04:22:47 AM
Hello magikarts,

Thank you very much for your purchase and support. I also have a MacBook Pro which I purchased for testing the programs. It sounds like you have done everything right, such as removing the Box Collider and using the correct keys so I'm surprised to hear it isn't working correctly.

The control/command key is now the designated hotkey and it should work with a left click on the cube. The brush or texture mode mentioned in the documentation is simply a checkbox option on the Mesh Painter window.

Given that you appear to have tried everything I could recommend I will need to perform some more tests and I will try to resolve this. Please also note that I wrote this program a long time ago when I was just starting to create tools for Unity and as such it isn't that good. It's okay for adding some text notes to basic objects but don't expect much more from it than that.

Thanks again for your understanding and I will try to get back to you as soon as possible with my test results.

Best regards,
Support / Can't Get Mesh Painter to Work
Last post by magikarts - August 31, 2017, 05:19:32 PM
I'm using Unity 2017 running on a 2015 MacBook Pro running Sierra 10.12.6.  I dragged a cube into the scene, removed the box collider and added a mesh collider.  I tried all combinations of Left Control/Left Command, Left Mouse/Right Mouse.  The button to change the hot key doesn't appear to work and using the mouse/control key combos just manipulate the scene navigation or manipulate the object. (right or left mouse click).  I also tried locking the mesh with the mesh editor and pressing texture mode; that didn't work.

I've read the documentation.  It says to make sure brush mode or text mode are selected. It doesn't say where or how do that or even what tool to change it in.  There's no brush or texture mode in Unity as far as I could tell except in the texture tool.  But then the object to paint is not selected. 

Please let me know how to get this tool working.  I need a good mesh painting tool and don't feel like spending the money when there's already a tool in mesh maker to do it.
News / Re: Mesh Maker Discounted 50% ...
Last post by Mcnary - August 18, 2017, 08:57:25 AM
Quote from: MediaGieant on September 16, 2014, 01:18:26 AM
Due to a long review time the special went until the 9th of September which was for some. The bundle of programs are now back to their normal price of $50 which is still a bargain at only $6.25 per program. Hopefully I can get in on a madness sale or a 24 hour deal to offer the collection at the reduced price again soon.

Any more discounts?
Support / Re: CSG Asset Crash
Last post by MediaGiant - July 14, 2017, 11:57:12 AM
Hi Navtek,

It appears that the Brush_door is parented to a door_pivot object which also has a mesh filter attached. So the program may be having trouble with the hierarchy. If you move the Brush_door object and attach it to the cubes object, the set the target to Target_wall and the brush to the Brush_door object it appears to work. I also extended the bottom of the cube so there wasn't a door sill at the bottom.

Sometimes the calculations don't work and you may need to adjust the epsilon value on the Settings page. It might take a bit of tweaking but if you could try the same I'm sure it will work.

Best regards,
Support / CSG Asset Crash
Last post by Navtek - July 14, 2017, 09:22:43 AM
Hi there,
I've purchased the CSG asset recently. It works fine in most cases.
But here is a case where Unity Crashes in both Editor mode and also at Runtime.
By crash I mean that the RAM increases continuously (by approx 50-100MB/sec) till the RAM usage is full and whole system crashes.
I've attached the Assets for simulating the scene and I've renamed the Brush and the Target gameobjects.

The settings in Editor Mode-
Hide original Objects = false.
Keep Submeshes = true.
Use custom material = false.

Note: You require CSG asset for the same (it is not included in the attachment).
Support / Re: Prefab Maker textures muck...
Last post by tezza - June 20, 2017, 08:41:23 PM
I checked and the textures have no tiling and all the coordinates are between 0,1

Would it help if I transmitted the mesh to you so you could investigate with your own tools or debug settings ?
Support / Re: Prefab Maker textures muck...
Last post by MediaGiant - June 20, 2017, 12:26:26 AM
Hello Tezza,

Thank you for using Prefab Maker. From the pictures I would say that the objects are using tiled textures, or at least texture coordinates that are outside of the range of 0 to 1. Prefab Maker isn't able to atlas these as it uses standard texture coordinates and cannot handle the tiled textures.

Would you be able to try a test with a couple of textured cubes or similar objects to see if this is the case?