Mesh Maker Forum
User Info
Welcome, Guest. Please login or register.
October 15, 2018, 12:01:32 PM

Login with username, password and session length
Search:     Advanced search
News
Latest addition to the collection: Prefab Maker
Forum Stats
152 Posts in 47 Topics by 58 Members
Latest Member: MikeD87
Home Help Search Login Register
Mesh Maker Forum  |  Recent Posts

Recent Posts

Pages: [1] 2 3 ... 10
1
Support / Re: A couple of requests for a future release
« Last post by MaxwellB on October 13, 2018, 12:25:59 PM »
Are there even going to be future releases? Will any of this be addressed? I see some good suggestions.
2
Support / Re: Level Editing Problems.
« Last post by Sotton on January 09, 2018, 04:46:27 AM »
I have the same problem with file types as Magikarts. All grayed out. Also checked the permissions and they're read and write. What else can I try?
3
FAQs / Level Editor , Mesh editor and constraction in Runtime
« Last post by darksire on October 04, 2017, 04:52:02 AM »
Hi is it possible to run Level Editor , Mesh editor and constraction in Runtime ? if no is it possible to change to code so it can ?
4
Support / A couple of requests for a future release
« Last post by ChrisT on September 25, 2017, 07:37:24 AM »
Hi, I bought Mesh Editor a few days back. I'll put my hand up and say firstly I come from a VFX background, starting with 3dsmax and later using XSI and Maya. As such, I am used to modelling using quads and say Turbosmooth (3dsmax). I would love to see a quad workflow in Mesh Editor, though I understand this may not be possible due to it not supporting quads as primitives? Not sure if this is the case.

 So, I'm making a game, where the landscape is going to be a regular grid, where some parts are raised, or lowered to form the level. Whilst modelling, to help keep this grid pattern in mind, I use a chequer material, this implies that the landscape is quad poly based.

Now, I WANT to treat the tri-mesh, as much as I can, as a quad mesh. So, here are some small wishes, along the way that would help a little in this respect.

1. The ability to select quads. This could be a simple rule in a quad select mode, that any tri selected, also selects the tri next to it, that shares its longest edge. I know, this is a little jungle, but it most cases, it would result in a "quad" select.

2. This one is more critical for my workflow. Quad tri rotation. Imagine you have a "quad" selected. The edge I need to rotate, is the one that both tri's in the "quad" share. Lets say, to start off with, this edge, runs from top left, to bottom right, like this \ . But because of how this folds, I need it to run from bottom left, to top right, like this / .So this tool keeps all of the verticies of these two tris, plus their UVs, but then re-defines the two tries to "rotate" the shared edge, from \ to /. Why do I need this? Well, take a grid mesh, select two tris in its middle, that form a "quad" and pull them upwards on Y. You now have a truncated pyramid. If you look from above, and look at the pyramids corners, you'll see that all 4 are like this \ \ \ \ (or the opposite). However, for the pyramid to appear symmetrical, those edge orientations need to alternate like top left \, top right /, bottom left /, bottom right \. This would make each corner smooth like all the others.

So, of the two wishes above, you can see that to do item 2 easily, item 1 would be ideal. Item 1 of course, if done, opens the gateway for other quad based workflows, like ring and loop selections and so on. But right now, that lack of both 1 and 2 above, would kind of force me to use something like 3dsmax or Maya to produce a good looking mesh for my game.
5
Support / Re: Level Editing Problems.
« Last post by magikarts on September 03, 2017, 01:20:06 PM »
I did check permissions on the files - they were read/write.  I made the change earlier because mesh painter wouldn't paint if the files were read only.
6
Support / Re: Level Editing Problems.
« Last post by MediaGiant on September 01, 2017, 10:13:24 PM »
First you would switch to Triangle mode within Level Editor, hold down the hotkey and click on a face (which will turn blue) and then press the Delete key. In Erase mode it will only erase the lines, but should be as easy as left clicking and dragging across the lines in the scene.

Thank you for the screenshot, it is puzzling to see that the PNG type is greyed out and I'm not exactly sure why this might be. It might be a permissions problem or a format issue since the blueprint was created in Windows. A bit more information can be found here at http://answers.unity3d.com/questions/593799/error-importing-png-file-could-not-be-read.html A way to test this would be to select another PNG file from the internet or elsewhere on the Mac. 
7
Support / Level Editing Problems.
« Last post by magikarts on September 01, 2017, 04:31:42 PM »
== Gear: MacBook Pro + OS 10. 12.6. 

== Delete
Tried selecting with a hot key and pressing the delete key.  Tried both the standard Delete key + ctrl-E (which deletes selected triangles in Mesh Editor).  Neither work in level editor.  Also tried selecting face then selecting the erase tool as well as selecting erase, then trying to select a face.  Also tried selecting lines. Nothing worked. Delete all works.  There is a work around: use the Mesh Editor or Mesh Cutter to delete what you want, but that involves saving the part and starting up another tool.

== Blueprints
All the legal file types (images) are greyed out, see screenshot.[blueprint load problem][www.http://magikarts.com/img/BlueprintLoadProblem.png]

8
Support / Re: Can't Get Mesh Painter to Work
« Last post by MediaGiant on August 31, 2017, 11:22:47 PM »
Hello magikarts,

Thank you very much for your purchase and support. I also have a MacBook Pro which I purchased for testing the programs. It sounds like you have done everything right, such as removing the Box Collider and using the correct keys so I'm surprised to hear it isn't working correctly.

The control/command key is now the designated hotkey and it should work with a left click on the cube. The brush or texture mode mentioned in the documentation is simply a checkbox option on the Mesh Painter window.

Given that you appear to have tried everything I could recommend I will need to perform some more tests and I will try to resolve this. Please also note that I wrote this program a long time ago when I was just starting to create tools for Unity and as such it isn't that good. It's okay for adding some text notes to basic objects but don't expect much more from it than that.

Thanks again for your understanding and I will try to get back to you as soon as possible with my test results.

Best regards,
Alan 
9
Support / Can't Get Mesh Painter to Work
« Last post by magikarts on August 31, 2017, 12:19:32 PM »
I'm using Unity 2017 running on a 2015 MacBook Pro running Sierra 10.12.6.  I dragged a cube into the scene, removed the box collider and added a mesh collider.  I tried all combinations of Left Control/Left Command, Left Mouse/Right Mouse.  The button to change the hot key doesn't appear to work and using the mouse/control key combos just manipulate the scene navigation or manipulate the object. (right or left mouse click).  I also tried locking the mesh with the mesh editor and pressing texture mode; that didn't work.

I've read the documentation.  It says to make sure brush mode or text mode are selected. It doesn't say where or how do that or even what tool to change it in.  There's no brush or texture mode in Unity as far as I could tell except in the texture tool.  But then the object to paint is not selected. 

Please let me know how to get this tool working.  I need a good mesh painting tool and don't feel like spending the money when there's already a tool in mesh maker to do it.
10
News / Re: Mesh Maker Discounted 50% until the end of August
« Last post by Mcnary on August 18, 2017, 03:57:25 AM »
Due to a long review time the special went until the 9th of September which was good look at the penimaster pro for some. The bundle of programs are now back to their normal price of $50 which is still a bargain at only $6.25 per program. Hopefully I can get in on a madness sale or a 24 hour deal to offer the collection at the reduced price again soon.


Any more discounts?
Pages: [1] 2 3 ... 10
SMF 2.0.6 | SMF © 2013, Simple Machines | Theme by nesianstyles | Buttons by Andrea